aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/doc/oidspecs/rfc/rfc4523.oidspec
diff options
context:
space:
mode:
authorDavid M. Syzdek <david@syzdek.net>2019-11-19 20:19:34 -0900
committerDavid M. Syzdek <david@syzdek.net>2019-11-19 20:19:34 -0900
commitf9254f53a75ca1ca227d1316f2e36aaeadd6c552 (patch)
tree255783ac9d80c39a4d2ac7c58d3cc4a9f60d9346 /doc/oidspecs/rfc/rfc4523.oidspec
parent93a84657fb7b8da29cc95a5050329eb164d2b857 (diff)
downloadldap-utils-f9254f53a75ca1ca227d1316f2e36aaeadd6c552.tar.gz
ldap-utils-f9254f53a75ca1ca227d1316f2e36aaeadd6c552.tar.bz2
ldap-utils-f9254f53a75ca1ca227d1316f2e36aaeadd6c552.tar.xz
ldap-utils-f9254f53a75ca1ca227d1316f2e36aaeadd6c552.zip
oidspecs: removing .abnf from 1.3.6.1.1.15.2 due to length issues
Diffstat (limited to '')
-rw-r--r--doc/oidspecs/rfc/rfc4523.oidspec238
1 files changed, 1 insertions, 237 deletions
diff --git a/doc/oidspecs/rfc/rfc4523.oidspec b/doc/oidspecs/rfc/rfc4523.oidspec
index 4b09af4..7c51c45 100644
--- a/doc/oidspecs/rfc/rfc4523.oidspec
+++ b/doc/oidspecs/rfc/rfc4523.oidspec
@@ -505,243 +505,7 @@
505 .type = LDAPSCHEMA_SYNTAX, 505 .type = LDAPSCHEMA_SYNTAX,
506 .class = LDAPSCHEMA_CLASS_ASCII, 506 .class = LDAPSCHEMA_CLASS_ASCII,
507 .def = "( 1.3.6.1.1.15.2 DESC 'X.509 Certificate Assertion' )", 507 .def = "( 1.3.6.1.1.15.2 DESC 'X.509 Certificate Assertion' )",
508 .abnf = "CertificateAssertion = \"{\" [ sp ca-serialNumber ]\n" 508 .abnf = NULL,
509 " [ sep sp ca-issuer ]\n"
510 " [ sep sp ca-subjectKeyIdentifier ]\n"
511 " [ sep sp ca-authorityKeyIdentifier ]\n"
512 " [ sep sp ca-certificateValid ]\n"
513 " [ sep sp ca-privateKeyValid ]\n"
514 " [ sep sp ca-subjectPublicKeyAlgID ]\n"
515 " [ sep sp ca-keyUsage ]\n"
516 " [ sep sp ca-subjectAltName ]\n"
517 " [ sep sp ca-policy ]\n"
518 " [ sep sp ca-pathToName ]\n"
519 " [ sep sp ca-subject ]\n"
520 " [ sep sp ca-nameConstraints ] sp \"}\"\n"
521 "\n"
522 "ca-serialNumber = id-serialNumber msp CertificateSerialNumber\n"
523 "ca-issuer = id-issuer msp Name\n"
524 "ca-subjectKeyIdentifier = id-subjectKeyIdentifier msp\n"
525 " SubjectKeyIdentifier\n"
526 "ca-authorityKeyIdentifier = id-authorityKeyIdentifier msp\n"
527 " AuthorityKeyIdentifier\n"
528 "ca-certificateValid = id-certificateValid msp Time\n"
529 "ca-privateKeyValid = id-privateKeyValid msp GeneralizedTime\n"
530 "ca-subjectPublicKeyAlgID = id-subjectPublicKeyAlgID msp\n"
531 " OBJECT-IDENTIFIER\n"
532 "ca-keyUsage = id-keyUsage msp KeyUsage\n"
533 "ca-subjectAltName = id-subjectAltName msp AltNameType\n"
534 "ca-policy = id-policy msp CertPolicySet\n"
535 "ca-pathToName = id-pathToName msp Name\n"
536 "ca-subject = id-subject msp Name\n"
537 "ca-nameConstraints = id-nameConstraints msp NameConstraintsSyntax\n"
538 "\n"
539 "id-subjectKeyIdentifier =\n"
540 " %x73.75.62.6A.65.63.74.4B.65.79.49.64.65.6E.74.69.66.69.65.72\n"
541 " ; 'subjectKeyIdentifier'\n"
542 "id-authorityKeyIdentifier =\n"
543 " %x61.75.74.68.6F.72.69.74.79.4B.65.79.49.64.65.6E.74.69.66.69.65.72\n"
544 " ; 'authorityKeyIdentifier'\n"
545 "id-certificateValid = %x63.65.72.74.69.66.69.63.61.74.65.56.61.6C.69.64\n"
546 " ; 'certificateValid'\n"
547 "id-privateKeyValid = %x70.72.69.76.61.74.65.4B.65.79.56.61.6C.69.64\n"
548 " ; 'privateKeyValid'\n"
549 "id-subjectPublicKeyAlgID =\n"
550 " %x73.75.62.6A.65.63.74.50.75.62.6C.69.63.4B.65.79.41.6C.67.49.44\n"
551 " ; 'subjectPublicKeyAlgID'\n"
552 "id-keyUsage = %x6B.65.79.55.73.61.67.65 ; 'keyUsage'\n"
553 "id-subjectAltName = %x73.75.62.6A.65.63.74.41.6C.74.4E.61.6D.65\n"
554 " ; 'subjectAltName'\n"
555 "id-policy = %x70.6F.6C.69.63.79 ; 'policy'\n"
556 "id-pathToName = %x70.61.74.68.54.6F.4E.61.6D.65 ; 'pathToName'\n"
557 "id-subject = %x73.75.62.6A.65.63.74 ; 'subject'\n"
558 "id-nameConstraints = %x6E.61.6D.65.43.6F.6E.73.74.72.61.69.6E.74.73\n"
559 " ; 'nameConstraints'\n"
560 "\n"
561 "SubjectKeyIdentifier = KeyIdentifier\n"
562 "\n"
563 "KeyIdentifier = OCTET-STRING\n"
564 "\n"
565 "AuthorityKeyIdentifier = \"{\" [ sp aki-keyIdentifier ]\n"
566 " [ sep sp aki-authorityCertIssuer ]\n"
567 " [ sep sp aki-authorityCertSerialNumber ] sp \"}\"\n"
568 "\n"
569 "aki-keyIdentifier = id-keyIdentifier msp KeyIdentifier\n"
570 "aki-authorityCertIssuer = id-authorityCertIssuer msp GeneralNames\n"
571 "\n"
572 "GeneralNames = \"{\" sp GeneralName *( \",\" sp GeneralName ) sp \"}\"\n"
573 "GeneralName = gn-otherName\n"
574 " / gn-rfc822Name\n"
575 " / gn-dNSName\n"
576 " / gn-x400Address\n"
577 " / gn-directoryName\n"
578 " / gn-ediPartyName\n"
579 " / gn-uniformResourceIdentifier\n"
580 " / gn-iPAddress\n"
581 " / gn-registeredID\n"
582 "\n"
583 "gn-otherName = id-otherName \":\" OtherName\n"
584 "gn-rfc822Name = id-rfc822Name \":\" IA5String\n"
585 "gn-dNSName = id-dNSName \":\" IA5String\n"
586 "gn-x400Address = id-x400Address \":\" ORAddress\n"
587 "gn-directoryName = id-directoryName \":\" Name\n"
588 "gn-ediPartyName = id-ediPartyName \":\" EDIPartyName\n"
589 "gn-iPAddress = id-iPAddress \":\" OCTET-STRING\n"
590 "gn-registeredID = gn-id-registeredID \":\" OBJECT-IDENTIFIER\n"
591 "\n"
592 "gn-uniformResourceIdentifier = id-uniformResourceIdentifier\n"
593 " \":\" IA5String\n"
594 "\n"
595 "id-otherName = %x6F.74.68.65.72.4E.61.6D.65 ; 'otherName'\n"
596 "gn-id-registeredID = %x72.65.67.69.73.74.65.72.65.64.49.44\n"
597 " ; 'registeredID'\n"
598 "\n"
599 "OtherName = \"{\" sp on-type-id \",\" sp on-value sp \"}\"\n"
600 "on-type-id = id-type-id msp OBJECT-IDENTIFIER\n"
601 "on-value = id-value msp Value\n"
602 " ;; <Value> as defined in Section 3 of [RFC3641]\n"
603 "\n"
604 "id-type-id = %x74.79.70.65.2D.69.64 ; 'type-id'\n"
605 "id-value = %x76.61.6C.75.65 ; 'value'\n"
606 "\n"
607 "ORAddress = dquote *SafeIA5Character dquote\n"
608 "SafeIA5Character = %x01-21 / %x23-7F / ; ASCII minus dquote\n"
609 " dquote dquote ; escaped double quote\n"
610 "dquote = %x22 ; '\"' (double quote)\n"
611 "\n"
612 ";; Note: The <ORAddress> rule encodes the x400Address component\n"
613 ";; of a GeneralName as a character string between double quotes.\n"
614 ";; The character string is first derived according to Section 4.1\n"
615 ";; of [RFC2156], and then any embedded double quotes are escaped\n"
616 ";; by being repeated. This resulting string is output between\n"
617 ";; double quotes.\n"
618 "\n"
619 "EDIPartyName = \"{\" [ sp nameAssigner \",\" ] sp partyName sp \"}\"\n"
620 "nameAssigner = id-nameAssigner msp DirectoryString\n"
621 "partyName = id-partyName msp DirectoryString\n"
622 "id-nameAssigner = %x6E.61.6D.65.41.73.73.69.67.6E.65.72\n"
623 " ; 'nameAssigner'\n"
624 "id-partyName = %x70.61.72.74.79.4E.61.6D.65 ; 'partyName'\n"
625 "\n"
626 "aki-authorityCertSerialNumber = id-authorityCertSerialNumber\n"
627 " msp CertificateSerialNumber\n"
628 "\n"
629 "id-keyIdentifier = %x6B.65.79.49.64.65.6E.74.69.66.69.65.72\n"
630 " ; 'keyIdentifier'\n"
631 "id-authorityCertIssuer =\n"
632 " %x61.75.74.68.6F.72.69.74.79.43.65.72.74.49.73.73.75.65.72\n"
633 " ; 'authorityCertIssuer'\n"
634 "\n"
635 "id-authorityCertSerialNumber = %x61.75.74.68.6F.72.69.74.79.43\n"
636 " %x65.72.74.53.65.72.69.61.6C.4E.75.6D.62.65.72\n"
637 " ; 'authorityCertSerialNumber'\n"
638 "\n"
639 "Time = time-utcTime / time-generalizedTime\n"
640 "time-utcTime = id-utcTime \":\" UTCTime\n"
641 "time-generalizedTime = id-generalizedTime \":\" GeneralizedTime\n"
642 "id-utcTime = %x75.74.63.54.69.6D.65 ; 'utcTime'\n"
643 "id-generalizedTime = %x67.65.6E.65.72.61.6C.69.7A.65.64.54.69.6D.65\n"
644 " ; 'generalizedTime'\n"
645 "\n"
646 "KeyUsage = BIT-STRING / key-usage-bit-list\n"
647 "key-usage-bit-list = \"{\" [ sp key-usage *( \",\" sp key-usage ) ] sp \"}\"\n"
648 "\n"
649 ";; Note: The <key-usage-bit-list> rule encodes the one bits in\n"
650 ";; a KeyUsage value as a comma separated list of identifiers.\n"
651 "\n"
652 "key-usage = id-digitalSignature\n"
653 " / id-nonRepudiation\n"
654 " / id-keyEncipherment\n"
655 " / id-dataEncipherment\n"
656 " / id-keyAgreement\n"
657 " / id-keyCertSign\n"
658 " / id-cRLSign\n"
659 " / id-encipherOnly\n"
660 " / id-decipherOnly\n"
661 "\n"
662 "id-digitalSignature = %x64.69.67.69.74.61.6C.53.69.67.6E.61.74\n"
663 " %x75.72.65 ; 'digitalSignature'\n"
664 "id-nonRepudiation = %x6E.6F.6E.52.65.70.75.64.69.61.74.69.6F.6E\n"
665 " ; 'nonRepudiation'\n"
666 "id-keyEncipherment = %x6B.65.79.45.6E.63.69.70.68.65.72.6D.65.6E.74\n"
667 " ; 'keyEncipherment'\n"
668 "id-dataEncipherment = %x64.61.74.61.45.6E.63.69.70.68.65.72.6D.65.6E\n"
669 " %x74 ; \"dataEncipherment'\n"
670 "id-keyAgreement = %x6B.65.79.41.67.72.65.65.6D.65.6E.74\n"
671 " ; 'keyAgreement'\n"
672 "id-keyCertSign = %x6B.65.79.43.65.72.74.53.69.67.6E\n"
673 " ; 'keyCertSign'\n"
674 "id-cRLSign = %x63.52.4C.53.69.67.6E ; \"cRLSign\"\n"
675 "id-encipherOnly = %x65.6E.63.69.70.68.65.72.4F.6E.6C.79\n"
676 " ; 'encipherOnly'\n"
677 "id-decipherOnly = %x64.65.63.69.70.68.65.72.4F.6E.6C.79\n"
678 " ; 'decipherOnly'\n"
679 "\n"
680 "AltNameType = ant-builtinNameForm / ant-otherNameForm\n"
681 "\n"
682 "ant-builtinNameForm = id-builtinNameForm \":\" BuiltinNameForm\n"
683 "ant-otherNameForm = id-otherNameForm \":\" OBJECT-IDENTIFIER\n"
684 "\n"
685 "id-builtinNameForm = %x62.75.69.6C.74.69.6E.4E.61.6D.65.46.6F.72.6D\n"
686 " ; 'builtinNameForm'\n"
687 "id-otherNameForm = %x6F.74.68.65.72.4E.61.6D.65.46.6F.72.6D\n"
688 " ; 'otherNameForm'\n"
689 "\n"
690 "BuiltinNameForm = id-rfc822Name\n"
691 " / id-dNSName\n"
692 " / id-x400Address\n"
693 " / id-directoryName\n"
694 " / id-ediPartyName\n"
695 " / id-uniformResourceIdentifier\n"
696 " / id-iPAddress\n"
697 " / id-registeredId\n"
698 "\n"
699 "id-rfc822Name = %x72.66.63.38.32.32.4E.61.6D.65 ; 'rfc822Name'\n"
700 "id-dNSName = %x64.4E.53.4E.61.6D.65 ; 'dNSName'\n"
701 "id-x400Address = %x78.34.30.30.41.64.64.72.65.73.73 ; 'x400Address'\n"
702 "id-directoryName = %x64.69.72.65.63.74.6F.72.79.4E.61.6D.65\n"
703 " ; 'directoryName'\n"
704 "id-ediPartyName = %x65.64.69.50.61.72.74.79.4E.61.6D.65\n"
705 " ; 'ediPartyName'\n"
706 "id-iPAddress = %x69.50.41.64.64.72.65.73.73 ; 'iPAddress'\n"
707 "id-registeredId = %x72.65.67.69.73.74.65.72.65.64.49.64\n"
708 " ; 'registeredId'\n"
709 "\n"
710 "id-uniformResourceIdentifier = %x75.6E.69.66.6F.72.6D.52.65.73.6F.75\n"
711 " %x72.63.65.49.64.65.6E.74.69.66.69.65.72\n"
712 " ; 'uniformResourceIdentifier'\n"
713 "\n"
714 "CertPolicySet = \"{\" sp CertPolicyId *( \",\" sp CertPolicyId ) sp \"}\"\n"
715 "CertPolicyId = OBJECT-IDENTIFIER\n"
716 "\n"
717 "NameConstraintsSyntax = \"{\" [ sp ncs-permittedSubtrees ]\n"
718 " [ sep sp ncs-excludedSubtrees ] sp \"}\"\n"
719 "\n"
720 "ncs-permittedSubtrees = id-permittedSubtrees msp GeneralSubtrees\n"
721 "ncs-excludedSubtrees = id-excludedSubtrees msp GeneralSubtrees\n"
722 "\n"
723 "id-permittedSubtrees =\n"
724 " %x70.65.72.6D.69.74.74.65.64.53.75.62.74.72.65.65.73\n"
725 " ; 'permittedSubtrees'\n"
726 "id-excludedSubtrees =\n"
727 " %x65.78.63.6C.75.64.65.64.53.75.62.74.72.65.65.73\n"
728 " ; 'excludedSubtrees'\n"
729 "\n"
730 "GeneralSubtrees = \"{\" sp GeneralSubtree\n"
731 " *( \",\" sp GeneralSubtree ) sp \"}\"\n"
732 "GeneralSubtree = \"{\" sp gs-base\n"
733 " [ \",\" sp gs-minimum ]\n"
734 " [ \",\" sp gs-maximum ] sp \"}\"\n"
735 "\n"
736 "gs-base = id-base msp GeneralName\n"
737 "gs-minimum = id-minimum msp BaseDistance\n"
738 "gs-maximum = id-maximum msp BaseDistance\n"
739 "\n"
740 "id-base = %x62.61.73.65 ; 'base'\n"
741 "id-minimum = %x6D.69.6E.69.6D.75.6D ; 'minimum'\n"
742 "id-maximum = %x6D.61.78.69.6D.75.6D ; 'maximum'\n"
743 "\n"
744 "BaseDistance = INTEGER-0-MAX\n",
745 .re_posix = NULL, 509 .re_posix = NULL,
746 .re_pcre = NULL, 510 .re_pcre = NULL,
747 .spec = "RFC 4523: LDAP X.509 Schema", 511 .spec = "RFC 4523: LDAP X.509 Schema",