aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/doc
diff options
context:
space:
mode:
authorDavid M. Syzdek <david@syzdek.net>2019-11-20 01:42:15 -0900
committerDavid M. Syzdek <david@syzdek.net>2019-11-20 01:42:15 -0900
commit48502fe72d627051daa77d5c44ba6607de160383 (patch)
tree63bb47db57290c9bb6c22cafe21d3c7f33581d9a /doc
parent6e61b2e1c557e4ee7fda4dec14fe6754a1550251 (diff)
downloadldap-utils-48502fe72d627051daa77d5c44ba6607de160383.tar.gz
ldap-utils-48502fe72d627051daa77d5c44ba6607de160383.tar.bz2
ldap-utils-48502fe72d627051daa77d5c44ba6607de160383.tar.xz
ldap-utils-48502fe72d627051daa77d5c44ba6607de160383.zip
oidspecs: adding OIDs from IANA LDAP Parameters reference
Diffstat (limited to 'doc')
-rw-r--r--doc/oidspecs/iana-ldap-parameters.oidspec648
1 files changed, 648 insertions, 0 deletions
diff --git a/doc/oidspecs/iana-ldap-parameters.oidspec b/doc/oidspecs/iana-ldap-parameters.oidspec
new file mode 100644
index 0000000..eff8cee
--- /dev/null
+++ b/doc/oidspecs/iana-ldap-parameters.oidspec
@@ -0,0 +1,648 @@
1// List of OIDs from
2// IANA Lightweight Directory Access Protocol (LDAP) Parameters
3// https://www.iana.org/assignments/ldap-parameters/ldap-parameters.xhtml
4//
5// OIDs should be moved to appropiate oidspec files as time permits.
6
7
8{
9 .oid = "1.2.826.0.1.3344810.2.3",
10 .name = "Matched Values Control",
11 .desc = "Matched Values Control",
12 .flags = 0,
13 .type = LDAPSCHEMA_CONTROL,
14 .def = NULL,
15 .spec = "RFC 3876: Returning Matched Values with the Lightweight Directory Access Protocol version 3 (LDAPv3)",
16 .spec_type = LDAPSCHEMA_SPEC_RFC,
17 .spec_name = "3876",
18 .spec_section = "2",
19 .spec_vendor = "IETF",
20};
21
22
23
24{
25 .oid = "1.2.840.113556.1.4.319",
26 .name = "LDAP Simple Paged Results Control",
27 .desc = "LDAP Simple Paged Results Control",
28 .flags = 0,
29 .type = LDAPSCHEMA_CONTROL,
30 .def = NULL,
31 .spec = "RFC 2696: LDAP Control Extension for Simple Paged Results Manipulation",
32 .spec_type = LDAPSCHEMA_SPEC_RFC,
33 .spec_name = "2696",
34 .spec_section = "2",
35 .spec_vendor = "IETF",
36};
37
38
39
40{
41 .oid = "1.2.840.113556.1.4.473",
42 .name = "Sort Request",
43 .desc = "Sort Request",
44 .flags = 0,
45 .type = LDAPSCHEMA_CONTROL,
46 .def = NULL,
47 .spec = "RFC 2891: LDAP Control Extension for Server Side Sorting of Search Results",
48 .spec_type = LDAPSCHEMA_SPEC_RFC,
49 .spec_name = "2891",
50 .spec_section = "1.1",
51 .spec_vendor = "IETF",
52};
53
54
55
56{
57 .oid = "1.2.840.113556.1.4.474",
58 .name = "Sort Response",
59 .desc = "Sort Response",
60 .flags = 0,
61 .type = LDAPSCHEMA_CONTROL,
62 .def = NULL,
63 .spec = "RFC 2891: LDAP Control Extension for Server Side Sorting of Search Results",
64 .spec_type = LDAPSCHEMA_SPEC_RFC,
65 .spec_name = "2891",
66 .spec_section = "1.2",
67 .spec_vendor = "IETF",
68};
69
70
71
72{
73 .oid = "1.3.6.1.1.7.1",
74 .name = "LCUP Sync Request Control",
75 .desc = "LCUP Sync Request Control",
76 .flags = 0,
77 .type = LDAPSCHEMA_CONTROL,
78 .def = NULL,
79 .spec = "RFC 3928: Lightweight Directory Access Protocol (LDAP) Client Update Protocol (LCUP)",
80 .spec_type = LDAPSCHEMA_SPEC_RFC,
81 .spec_name = "3928",
82 .spec_section = "3.6",
83 .spec_vendor = "IETF",
84};
85
86
87
88{
89 .oid = "1.3.6.1.1.7.2",
90 .name = "LCUP Sync Update Control",
91 .desc = "LCUP Sync Update Control",
92 .flags = 0,
93 .type = LDAPSCHEMA_CONTROL,
94 .def = NULL,
95 .spec = "RFC 3928: Lightweight Directory Access Protocol (LDAP) Client Update Protocol (LCUP)",
96 .spec_type = LDAPSCHEMA_SPEC_RFC,
97 .spec_name = "3928",
98 .spec_section = "3.7",
99 .spec_vendor = "IETF",
100};
101
102
103
104{
105 .oid = "1.3.6.1.1.7.3",
106 .name = "LCUP Sync Done Control",
107 .desc = "LCUP Sync Done Control",
108 .flags = 0,
109 .type = LDAPSCHEMA_CONTROL,
110 .def = NULL,
111 .spec = "RFC 3928: Lightweight Directory Access Protocol (LDAP) Client Update Protocol (LCUP)",
112 .spec_type = LDAPSCHEMA_SPEC_RFC,
113 .spec_name = "3928",
114 .spec_section = "3.8",
115 .spec_vendor = "IETF",
116};
117
118
119
120{
121 .oid = "1.3.6.1.1.12",
122 .name = "Assertion Control",
123 .desc = "Assertion Control",
124 .flags = 0,
125 .type = LDAPSCHEMA_CONTROL,
126 .def = NULL,
127 .spec = "RFC 4528: Lightweight Directory Access Protocol (LDAP) Assertion Control",
128 .spec_type = LDAPSCHEMA_SPEC_RFC,
129 .spec_name = "4528",
130 .spec_section = "3",
131 .spec_vendor = "IETF",
132};
133
134
135
136{
137 .oid = "1.3.6.1.1.13.1",
138 .name = "LDAP Pre-read Control",
139 .desc = "LDAP Pre-read Control",
140 .flags = 0,
141 .type = LDAPSCHEMA_CONTROL,
142 .def = NULL,
143 .spec = "RFC 4527: Lightweight Directory Access Protocol (LDAP) Read Entry Controls",
144 .spec_type = LDAPSCHEMA_SPEC_RFC,
145 .spec_name = "4527",
146 .spec_section = "3.1",
147 .spec_vendor = "IETF",
148};
149
150
151
152{
153 .oid = "1.3.6.1.1.13.2",
154 .name = "LDAP Post-read Control",
155 .desc = "LDAP Post-read Control",
156 .flags = 0,
157 .type = LDAPSCHEMA_CONTROL,
158 .def = NULL,
159 .spec = "RFC 4527: Lightweight Directory Access Protocol (LDAP) Read Entry Controls",
160 .spec_type = LDAPSCHEMA_SPEC_RFC,
161 .spec_name = "4527",
162 .spec_section = "3.2",
163 .spec_vendor = "IETF",
164};
165
166
167
168{
169 .oid = "1.3.6.1.1.21.2",
170 .name = "Transaction Specification Control",
171 .desc = "Transaction Specification Control",
172 .flags = 0,
173 .type = LDAPSCHEMA_CONTROL,
174 .def = NULL,
175 .spec = "RFC 5805: Lightweight Directory Access Protocol (LDAP) Transactions",
176 .spec_type = LDAPSCHEMA_SPEC_RFC,
177 .spec_name = "5805",
178 .spec_section = "2.2",
179 .spec_vendor = "IETF",
180};
181
182
183
184{
185 .oid = "1.3.6.1.4.1.4203.1.9.1.1",
186 .name = "LDAP Content Synchronization Control",
187 .desc = "LDAP Content Synchronization Control",
188 .flags = 0,
189 .type = LDAPSCHEMA_CONTROL,
190 .def = NULL,
191 .spec = "RFC 4533: The Lightweight Directory Access Protocol (LDAP) Content Synchronization Operation",
192 .spec_type = LDAPSCHEMA_SPEC_RFC,
193 .spec_name = "4533",
194 .spec_section = "2",
195 .spec_vendor = "IETF",
196};
197
198
199
200{
201 .oid = "1.3.6.1.4.1.4203.1.10.1",
202 .name = "Subentries",
203 .desc = "Subentries",
204 .flags = 0,
205 .type = LDAPSCHEMA_CONTROL,
206 .def = NULL,
207 .spec = "RFC 3672: Subentries in the Lightweight Directory Access Protocol (LDAP)",
208 .spec_type = LDAPSCHEMA_SPEC_RFC,
209 .spec_name = "3672",
210 .spec_section = "3",
211 .spec_vendor = "IETF",
212};
213
214
215
216{
217 .oid = "2.16.840.1.113730.3.4.2",
218 .name = "ManageDsaIT",
219 .desc = "ManageDsaIT",
220 .flags = 0,
221 .type = LDAPSCHEMA_CONTROL,
222 .def = NULL,
223 .spec = "RFC 3296: Named Subordinate References in Lightweight Directory Access Protocol (LDAP) Directories",
224 .spec_type = LDAPSCHEMA_SPEC_RFC,
225 .spec_name = "3296",
226 .spec_section = "3",
227 .spec_vendor = "IETF",
228};
229
230
231
232{
233 .oid = "2.16.840.1.113730.3.4.15",
234 .name = "Authorization Identity Response Control",
235 .desc = "Authorization Identity Response Control",
236 .flags = 0,
237 .type = LDAPSCHEMA_CONTROL,
238 .def = NULL,
239 .spec = "RFC 3829: Lightweight Directory Access Protocol (LDAP) Authorization Identity Request and Response Controls",
240 .spec_type = LDAPSCHEMA_SPEC_RFC,
241 .spec_name = "3829",
242 .spec_section = "2",
243 .spec_vendor = "IETF",
244};
245
246
247
248{
249 .oid = "2.16.840.1.113730.3.4.16",
250 .name = "Authorization Identity Request Control",
251 .desc = "Authorization Identity Request Control",
252 .flags = 0,
253 .type = LDAPSCHEMA_CONTROL,
254 .def = NULL,
255 .spec = "RFC 3829: Lightweight Directory Access Protocol (LDAP) Authorization Identity Request and Response Controls",
256 .spec_type = LDAPSCHEMA_SPEC_RFC,
257 .spec_name = "3829",
258 .spec_section = "3",
259 .spec_vendor = "IETF",
260};
261
262
263
264{
265 .oid = "2.16.840.1.113730.3.4.18",
266 .name = "Proxy Authorization Control",
267 .desc = "Proxy Authorization Control",
268 .flags = 0,
269 .type = LDAPSCHEMA_CONTROL,
270 .def = NULL,
271 .spec = "RFC 4370: Lightweight Directory Access Protocol (LDAP) Proxied Authorization Control",
272 .spec_type = LDAPSCHEMA_SPEC_RFC,
273 .spec_name = "4370",
274 .spec_section = "2",
275 .spec_vendor = "IETF",
276};
277
278
279
280{
281 .oid = "1.3.6.1.1.22",
282 .name = "LDAP Don't Use Copy Control",
283 .desc = "LDAP Don't Use Copy Control",
284 .flags = 0,
285 .type = LDAPSCHEMA_CONTROL,
286 .def = NULL,
287 .spec = "RFC 6171: The Lightweight Directory Access Protocol (LDAP) Don't Use Copy Control",
288 .spec_type = LDAPSCHEMA_SPEC_RFC,
289 .spec_name = "6171",
290 .spec_section = "3",
291 .spec_vendor = "IETF",
292};
293
294
295
296{
297 .oid = "1.3.6.1.1.8",
298 .name = "Cancel Operation",
299 .desc = "Cancel Operation",
300 .flags = 0,
301 .type = LDAPSCHEMA_EXTENSION,
302 .def = NULL,
303 .spec = "RFC 3909: Lightweight Directory Access Protocol (LDAP) Cancel Operation",
304 .spec_type = LDAPSCHEMA_SPEC_RFC,
305 .spec_name = "6171",
306 .spec_section = "2",
307 .spec_vendor = "IETF",
308};
309
310
311
312{
313 .oid = "1.3.6.1.1.21.1",
314 .name = "Start Transaction Extended Request",
315 .desc = "Start Transaction Extended Request",
316 .flags = 0,
317 .type = LDAPSCHEMA_EXTENSION,
318 .def = NULL,
319 .spec = "RFC 5805: Lightweight Directory Access Protocol (LDAP) Transactions",
320 .spec_type = LDAPSCHEMA_SPEC_RFC,
321 .spec_name = "5805",
322 .spec_section = "2.1",
323 .spec_vendor = "IETF",
324};
325
326
327
328{
329 .oid = "1.3.6.1.1.21.3",
330 .name = "End Transaction Extended Request",
331 .desc = "End Transaction Extended Request",
332 .flags = 0,
333 .type = LDAPSCHEMA_EXTENSION,
334 .def = NULL,
335 .spec = "RFC 5805: Lightweight Directory Access Protocol (LDAP) Transactions",
336 .spec_type = LDAPSCHEMA_SPEC_RFC,
337 .spec_name = "5805",
338 .spec_section = "2.3",
339 .spec_vendor = "IETF",
340};
341
342
343
344{
345 .oid = "1.3.6.1.4.1.1466.101.119.1",
346 .name = "Dynamic Refresh",
347 .desc = "Dynamic Refresh",
348 .flags = 0,
349 .type = LDAPSCHEMA_EXTENSION,
350 .def = NULL,
351 .spec = "RFC 2589: Lightweight Directory Access Protocol (v3): Extensions for Dynamic Directory Services",
352 .spec_type = LDAPSCHEMA_SPEC_RFC,
353 .spec_name = "2589",
354 .spec_section = "4.1",
355 .spec_vendor = "IETF",
356};
357
358
359
360{
361 .oid = "1.3.6.1.4.1.1466.20037",
362 .name = "StartTLS",
363 .desc = "StartTLS",
364 .flags = 0,
365 .type = LDAPSCHEMA_EXTENSION,
366 .def = NULL,
367 .spec = "RFC 4511: Lightweight Directory Access Protocol (LDAP): The Protocol",
368 .spec_type = LDAPSCHEMA_SPEC_RFC,
369 .spec_name = "4511",
370 .spec_section = "4.14.1",
371 .spec_vendor = "IETF",
372};
373
374
375
376{
377 .oid = "1.3.6.1.4.1.4203.1.11.1",
378 .name = "Modify Password",
379 .desc = "Modify Password",
380 .flags = 0,
381 .type = LDAPSCHEMA_EXTENSION,
382 .def = NULL,
383 .spec = "RFC 3062: LDAP Password Modify Extended Operation",
384 .spec_type = LDAPSCHEMA_SPEC_RFC,
385 .spec_name = "3062",
386 .spec_section = "2",
387 .spec_vendor = "IETF",
388};
389
390
391
392{
393 .oid = "1.3.6.1.4.1.4203.1.11.3",
394 .name = "Who am I?",
395 .desc = "Who am I?",
396 .flags = 0,
397 .type = LDAPSCHEMA_EXTENSION,
398 .def = NULL,
399 .spec = "RFC 4532: Lightweight Directory Access Protocol (LDAP) \"Who am I?\" Operation",
400 .spec_type = LDAPSCHEMA_SPEC_RFC,
401 .spec_name = "4532",
402 .spec_section = "2",
403 .spec_vendor = "IETF",
404};
405
406
407
408{
409 .oid = "1.3.6.1.1.17.1",
410 .name = "StartLBURPRequest LDAP ExtendedRequest message",
411 .desc = "StartLBURPRequest LDAP ExtendedRequest message",
412 .flags = 0,
413 .type = LDAPSCHEMA_EXTENSION,
414 .def = NULL,
415 .spec = "RFC 4373: Lightweight Directory Access Protocol (LDAP) Bulk Update/Replication Protocol (LBURP)",
416 .spec_type = LDAPSCHEMA_SPEC_RFC,
417 .spec_name = "4373",
418 .spec_section = "5.1",
419 .spec_vendor = "IETF",
420};
421
422
423
424{
425 .oid = "1.3.6.1.1.17.2",
426 .name = "StartLBURPResponse LDAP ExtendedResponse message",
427 .desc = "StartLBURPResponse LDAP ExtendedResponse message",
428 .flags = 0,
429 .type = LDAPSCHEMA_EXTENSION,
430 .def = NULL,
431 .spec = "RFC 4373: Lightweight Directory Access Protocol (LDAP) Bulk Update/Replication Protocol (LBURP)",
432 .spec_type = LDAPSCHEMA_SPEC_RFC,
433 .spec_name = "4373",
434 .spec_section = "5.2",
435 .spec_vendor = "IETF",
436};
437
438
439
440{
441 .oid = "1.3.6.1.1.17.3",
442 .name = "EndLBURPRequest LDAP ExtendedRequest message",
443 .desc = "EndLBURPRequest LDAP ExtendedRequest message",
444 .flags = 0,
445 .type = LDAPSCHEMA_EXTENSION,
446 .def = NULL,
447 .spec = "RFC 4373: Lightweight Directory Access Protocol (LDAP) Bulk Update/Replication Protocol (LBURP)",
448 .spec_type = LDAPSCHEMA_SPEC_RFC,
449 .spec_name = "4373",
450 .spec_section = "5.5",
451 .spec_vendor = "IETF",
452};
453
454
455
456{
457 .oid = "1.3.6.1.1.17.4",
458 .name = "EndLBURPResponse LDAP ExtendedResponse message",
459 .desc = "EndLBURPResponse LDAP ExtendedResponse message",
460 .flags = 0,
461 .type = LDAPSCHEMA_EXTENSION,
462 .def = NULL,
463 .spec = "RFC 4373: Lightweight Directory Access Protocol (LDAP) Bulk Update/Replication Protocol (LBURP)",
464 .spec_type = LDAPSCHEMA_SPEC_RFC,
465 .spec_name = "4373",
466 .spec_section = "5.6",
467 .spec_vendor = "IETF",
468};
469
470
471
472{
473 .oid = "1.3.6.1.1.17.5",
474 .name = "LBURPUpdateRequest LDAP ExtendedRequest message",
475 .desc = "LBURPUpdateRequest LDAP ExtendedRequest message",
476 .flags = 0,
477 .type = LDAPSCHEMA_EXTENSION,
478 .def = NULL,
479 .spec = "RFC 4373: Lightweight Directory Access Protocol (LDAP) Bulk Update/Replication Protocol (LBURP)",
480 .spec_type = LDAPSCHEMA_SPEC_RFC,
481 .spec_name = "4373",
482 .spec_section = "5.3",
483 .spec_vendor = "IETF",
484};
485
486
487
488{
489 .oid = "1.3.6.1.1.17.6",
490 .name = "LBURPUpdateResponse LDAP ExtendedResponse message",
491 .desc = "LBURPUpdateResponse LDAP ExtendedResponse message",
492 .flags = 0,
493 .type = LDAPSCHEMA_EXTENSION,
494 .def = NULL,
495 .spec = "RFC 4373: Lightweight Directory Access Protocol (LDAP) Bulk Update/Replication Protocol (LBURP)",
496 .spec_type = LDAPSCHEMA_SPEC_RFC,
497 .spec_name = "4373",
498 .spec_section = "5.4",
499 .spec_vendor = "IETF",
500};
501
502
503
504{
505 .oid = "1.3.6.1.1.19",
506 .name = "LDAP Turn Operation",
507 .desc = "LDAP Turn Operation",
508 .flags = 0,
509 .type = LDAPSCHEMA_EXTENSION,
510 .def = NULL,
511 .spec = "RFC 4531: Lightweight Directory Access Protocol (LDAP) Turn Operation",
512 .spec_type = LDAPSCHEMA_SPEC_RFC,
513 .spec_name = "4531",
514 .spec_section = "2",
515 .spec_vendor = "IETF",
516};
517
518
519
520{
521 .oid = "1.3.6.1.1.14",
522 .name = "Modify-Increment",
523 .desc = "Modify-Increment",
524 .flags = 0,
525 .type = LDAPSCHEMA_FEATURE,
526 .def = NULL,
527 .spec = "RFC 4525: Lightweight Directory Access Protocol (LDAP) Modify-Increment Extension",
528 .spec_type = LDAPSCHEMA_SPEC_RFC,
529 .spec_name = "4525",
530 .spec_section = "2",
531 .spec_vendor = "IETF",
532};
533
534
535
536{
537 .oid = "1.3.6.1.4.1.4203.1.5.1",
538 .name = "All Op Attrs",
539 .desc = "All Op Attrs",
540 .flags = 0,
541 .type = LDAPSCHEMA_FEATURE,
542 .def = NULL,
543 .spec = "RFC 3673: Lightweight Directory Access Protocol version 3 (LDAPv3): All Operational Attributes",
544 .spec_type = LDAPSCHEMA_SPEC_RFC,
545 .spec_name = "3673",
546 .spec_section = "2",
547 .spec_vendor = "IETF",
548};
549
550
551
552{
553 .oid = "1.3.6.1.4.1.4203.1.5.2",
554 .name = "OC AD Lists",
555 .desc = "OC AD Lists",
556 .flags = 0,
557 .type = LDAPSCHEMA_FEATURE,
558 .def = NULL,
559 .spec = "RFC 4529: Requesting Attributes by Object Class in the Lightweight Directory Access Protocol (LDAP)",
560 .spec_type = LDAPSCHEMA_SPEC_RFC,
561 .spec_name = "4529",
562 .spec_section = "3",
563 .spec_vendor = "IETF",
564};
565
566
567
568{
569 .oid = "1.3.6.1.4.1.4203.1.5.3",
570 .name = "True/False filters",
571 .desc = "True/False filters",
572 .flags = 0,
573 .type = LDAPSCHEMA_FEATURE,
574 .def = NULL,
575 .spec = "RFC 4526: Lightweight Directory Access Protocol (LDAP) Absolute True and False Filters",
576 .spec_type = LDAPSCHEMA_SPEC_RFC,
577 .spec_name = "4526",
578 .spec_section = "2",
579 .spec_vendor = "IETF",
580};
581
582
583
584{
585 .oid = "1.3.6.1.4.1.4203.1.5.4",
586 .name = "Language Tag Options",
587 .desc = "Language Tag Options",
588 .flags = 0,
589 .type = LDAPSCHEMA_FEATURE,
590 .def = NULL,
591 .spec = "RFC 3866: Language Tags and Ranges in the Lightweight Directory Access Protocol (LDAP)",
592 .spec_type = LDAPSCHEMA_SPEC_RFC,
593 .spec_name = "3866",
594 .spec_section = "4",
595 .spec_vendor = "IETF",
596};
597
598
599
600{
601 .oid = "1.3.6.1.4.1.4203.1.5.5",
602 .name = "Language Range Options",
603 .desc = "Language Range Options",
604 .flags = 0,
605 .type = LDAPSCHEMA_FEATURE,
606 .def = NULL,
607 .spec = "RFC 3866: Language Tags and Ranges in the Lightweight Directory Access Protocol (LDAP)",
608 .spec_type = LDAPSCHEMA_SPEC_RFC,
609 .spec_name = "3866",
610 .spec_section = "4",
611 .spec_vendor = "IETF",
612};
613
614
615
616{
617 .oid = "1.3.6.1.1.17.7",
618 .name = "LBURP Incremental Update style OID",
619 .desc = "LBURP Incremental Update style OID",
620 .flags = 0,
621 .type = LDAPSCHEMA_FEATURE,
622 .def = NULL,
623 .spec = "RFC 4373: Lightweight Directory Access Protocol (LDAP) Bulk Update/Replication Protocol (LBURP)",
624 .spec_type = LDAPSCHEMA_SPEC_RFC,
625 .spec_name = "4373",
626 .spec_section = "5.1.1",
627 .spec_vendor = "IETF",
628};
629
630
631
632{
633 .oid = "1.3.6.1.1.21.4",
634 .name = "Aborted Transaction Notice",
635 .desc = "Aborted Transaction Notice",
636 .flags = 0,
637 .type = LDAPSCHEMA_NAMEFORM,
638 .def = NULL,
639 .spec = "RFC 5805: Lightweight Directory Access Protocol (LDAP) Transactions",
640 .spec_type = LDAPSCHEMA_SPEC_RFC,
641 .spec_name = "5805",
642 .spec_section = "2.4",
643 .spec_vendor = "IETF",
644};
645
646
647
648// end of OID spec file