aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/TODO.md
blob: e6b5b4e98e74d12d80e88006b97195eb267850b1 (plain) (blame)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95

LDAP Utilities
Copyright (c) 2019 David M. Syzdek <david@syzdek.net>.
All rights reserved.

   - [x] ldap2csv

   - [x] ldapdebug

   - [ ] ldapdiff
     - [ ] write utility which compares results of two LDAP searches
     - [ ] write man page

   - [x] ldapdn2str
     - [ ] write man page

   - [ ] ldapinfo
     - [ ] write utility which displays LDAP server information
     - [ ] write man page

   - [ ] ldapshema
     - [ ] write utility which displays schema in human readable format
     - [ ] write man page
     - [ ] add support for matchingRules

   - [ ] ldaptlscert
     - [ ] write utility which retrieves LDAP server's TLS certificate
     - [ ] write man page

   - [x] ldaptree
     - [ ] add ability to display number of truncated entries

   - [ ] ldaplint
     - [ ] write utility which validats LDAP entries against schema
     - [ ] write man page

   - [ ] ldif2csv
     - [ ] white utility which converts LDIF to CSV file
     - [ ] write man page

   - [ ] ldifdiff
     - [ ] write utility which compares two LDIFs
     - [ ] write man page

   - [ ] ldiflint
     - [ ] write utility which validats LDIF against schema
     - [ ] write man page

   - [ ] ldifsort
     - [ ] write utility which parses and sorts LDIF
     - [ ] write man page

   - [x] libldapschema
     - [ ] add support for multiple objectClass superiors
     - [ ] write man pages
     - [x] add support for OID specs on attributeTypes and objectClasses
     - [x] add support for matchingRules

   - [x] libldaputils
     - [ ] add support for auth mechanisms other than simple auth.
     - [ ] write LDIF parser
     - [ ] write shema parser
     - [ ] write LDAPUtilsEntries to CSV file

   - [x] oidspectool
      - [ ] complete README.md
      - [ ] review OID specs in rfc/rfc2252.oidspec
      - [ ] review OID specs in rfc/rfc4517.oidspec
      - [ ] review OID specs in rfc/rfc4523.oidspec
      - [ ] review OID specs in rfc/rfc4530.oidspec
      - [ ] extract OID specs from RFC 2589: Lightweight Directory Access Protocol (v3): Extensions for Dynamic Directory Services
      - [ ] extract OID specs from RFC 2696: LDAP Control Extension for Simple Paged Results Manipulation
      - [ ] extract OID specs from RFC 2891: LDAP Control Extension for Server Side Sorting of Search Results
      - [ ] extract OID specs from RFC 3062: LDAP Password Modify Extended Operation
      - [ ] extract OID specs from RFC 3296: Named Subordinate References in Lightweight Directory Access Protocol (LDAP) Directories
      - [ ] extract OID specs from RFC 3672: Subentries in the Lightweight Directory Access Protocol (LDAP)
      - [ ] extract OID specs from RFC 3673: Lightweight Directory Access Protocol version 3 (LDAPv3): All Operational Attributes
      - [ ] extract OID specs from RFC 3829: Lightweight Directory Access Protocol (LDAP) Authorization Identity Request and Response Controls
      - [ ] extract OID specs from RFC 3866: Language Tags and Ranges in the Lightweight Directory Access Protocol (LDAP)
      - [ ] extract OID specs from RFC 3876: Returning Matched Values with the Lightweight Directory Access Protocol version 3 (LDAPv3)
      - [ ] extract OID specs from RFC 3909: Lightweight Directory Access Protocol (LDAP) Cancel Operation
      - [ ] extract OID specs from RFC 3928: Lightweight Directory Access Protocol (LDAP) Client Update Protocol (LCUP)
      - [ ] extract OID specs from RFC 4370: Lightweight Directory Access Protocol (LDAP) Proxied Authorization Control
      - [ ] extract OID specs from RFC 4373: Lightweight Directory Access Protocol (LDAP) Bulk Update/Replication Protocol (LBURP)
      - [ ] extract OID specs from RFC 4511: Lightweight Directory Access Protocol (LDAP): The Protocol
      - [ ] extract OID specs from RFC 4525: Lightweight Directory Access Protocol (LDAP) Modify-Increment Extension
      - [ ] extract OID specs from RFC 4526: Lightweight Directory Access Protocol (LDAP) Absolute True and False Filters
      - [ ] extract OID specs from RFC 4527: Lightweight Directory Access Protocol (LDAP) Read Entry Controls
      - [ ] extract OID specs from RFC 4528: Lightweight Directory Access Protocol (LDAP) Assertion Control
      - [ ] extract OID specs from RFC 4529: Requesting Attributes by Object Class in the Lightweight Directory Access Protocol (LDAP)
      - [ ] extract OID specs from RFC 4531: Lightweight Directory Access Protocol (LDAP) Turn Operation
      - [ ] extract OID specs from RFC 4532: Lightweight Directory Access Protocol (LDAP) "Who am I?" Operation
      - [ ] extract OID specs from RFC 4533: The Lightweight Directory Access Protocol (LDAP) Content Synchronization Operation
      - [ ] extract OID specs from RFC 5805: Lightweight Directory Access Protocol (LDAP) Transactions
      - [ ] extract OID specs from RFC 6171: The Lightweight Directory Access Protocol (LDAP) Don't Use Copy Control