aboutsummaryrefslogtreecommitdiffstatshomepage
path: root/include
diff options
context:
space:
mode:
authorDavid M. Syzdek <david@syzdek.net>2022-02-11 12:21:19 -0900
committerDavid M. Syzdek <david@syzdek.net>2022-02-11 12:21:19 -0900
commit57edd81838c83234a4fedc4c66d9a58b6dbf0a04 (patch)
treef1696ee62664ad2f0c015b71d66ccf8a1016ff76 /include
parent67dbb8e39b9044f41723997877b5c9f85e044490 (diff)
downloadtinyrad-57edd81838c83234a4fedc4c66d9a58b6dbf0a04.tar.gz
tinyrad-57edd81838c83234a4fedc4c66d9a58b6dbf0a04.tar.bz2
tinyrad-57edd81838c83234a4fedc4c66d9a58b6dbf0a04.tar.xz
tinyrad-57edd81838c83234a4fedc4c66d9a58b6dbf0a04.zip
libtinyrad: updating TinyRadURLDesc typedef
Diffstat (limited to 'include')
-rw-r--r--include/tinyrad.h7
1 files changed, 3 insertions, 4 deletions
diff --git a/include/tinyrad.h b/include/tinyrad.h
index a07ed80..7ad2802 100644
--- a/include/tinyrad.h
+++ b/include/tinyrad.h
@@ -251,7 +251,6 @@ typedef struct _tinyrad_dict TinyRadDict;
251typedef struct _tinyrad_dict_attr TinyRadDictAttr; 251typedef struct _tinyrad_dict_attr TinyRadDictAttr;
252typedef struct _tinyrad_dict_value TinyRadDictValue; 252typedef struct _tinyrad_dict_value TinyRadDictValue;
253typedef struct _tinyrad_dict_vendor TinyRadDictVendor; 253typedef struct _tinyrad_dict_vendor TinyRadDictVendor;
254typedef struct tinyrad_url_desc TinyRadURLDesc;
255typedef struct sockaddr_storage TinyRadSockAddr; 254typedef struct sockaddr_storage TinyRadSockAddr;
256 255
257 256
@@ -302,17 +301,17 @@ typedef struct tinyrad_map
302// radius-acct://hostport/secret[?proto] (default proto: udp, port: 1813) [RFC2866] 301// radius-acct://hostport/secret[?proto] (default proto: udp, port: 1813) [RFC2866]
303// radsec://hostport/[?proto] (default proto: tcp, port: 2083) [RFC6614/RFC7360] 302// radsec://hostport/[?proto] (default proto: tcp, port: 2083) [RFC6614/RFC7360]
304// radius-dynauth://hostport/secret[?proto] (default proto: udp, port: 3799) [RFC5176] 303// radius-dynauth://hostport/secret[?proto] (default proto: udp, port: 3799) [RFC5176]
305struct tinyrad_url_desc 304typedef struct tinyrad_url_desc
306{ 305{
307 char * trud_host; 306 char * trud_host;
308 char * trud_secret; 307 char * trud_secret;
309 int trud_port; 308 int trud_port;
310 unsigned trud_opts; 309 unsigned trud_opts;
311 /* may contain additional fields for internal use */ 310 /* may contain additional fields for internal use */
312 TinyRadURLDesc * trud_next; 311 struct tinyrad_url_desc * trud_next;
313 TinyRadSockAddr ** sockaddrs; 312 TinyRadSockAddr ** sockaddrs;
314 size_t sockaddrs_len; 313 size_t sockaddrs_len;
315}; 314} TinyRadURLDesc;
316 315
317 316
318////////////////// 317//////////////////